ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

View previous topic View next topic Go down

ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by FASFOX89 on Fri Jun 24, 2011 9:47 am

ok...here goes... starter engaged and wouldn't stop even after turning the key off.. i put in a new starter solenoid switch and replaced the battery ground cable which was corroded as hell..now the car will only start with a jump and has no hangups with the starter but will not restart after turned off...tested the battery sitting and reads just a tad over 12v. jumped the car and with it idling is reading 13.8v. so I guess that rules out the battery and alternator? correct? i'm on to the next step...Ignition switch? ? or turn signal/wiper control lever..my wiper motor does not go?? but everything else works in that lever...squirter ,turn signals(although the left side is not illuminated in the gauges) but its working,and hi beams working also..where else could i be shorting out?? the starter looks brand new and the ground cable to the starter looks brand new as well..i was looking online and late model restoration has an ignition switch for like 23 bucks..i looked it up at autozone and they have one and only want like 13 bucks...if i do get one ..which one should i get?..is the autozone switch a cheap one??..sorry if this is confusing you all but i'm at a loss and need some guidance here... its been a long time since my foxbody days and i definetly need some memory refreshing...thanx in advance for the help you all Smile
avatar
FASFOX89
BOSS
BOSS

Number of posts : 390
Age : 57
Location : Harford county,HdG
Registration date : 2011-06-05

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by TT_05_Stang on Fri Jun 24, 2011 10:27 am

Battery should be reading 13-14 volts at all times.

If it engages and stays running ignition relay is stuck.

_________________
Black 05 Stang
Current Mods: ProLine Shortblock, TurboHorsepower Twin Turbo
Numbers: 15psi, 17* timing, 722rwhp 649 rwtq on a Mustang Dyno... when it's running...
Tuner: Frank Soldridge PSI Motorsports Inc.
avatar
TT_05_Stang
Admin
Admin

Number of posts : 5329
Age : 42
Location : Arnold, MD
Registration date : 2007-12-07

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by TT_05_Stang on Fri Jun 24, 2011 10:28 am

Ignition relays from the parts store is fine.

_________________
Black 05 Stang
Current Mods: ProLine Shortblock, TurboHorsepower Twin Turbo
Numbers: 15psi, 17* timing, 722rwhp 649 rwtq on a Mustang Dyno... when it's running...
Tuner: Frank Soldridge PSI Motorsports Inc.
avatar
TT_05_Stang
Admin
Admin

Number of posts : 5329
Age : 42
Location : Arnold, MD
Registration date : 2007-12-07

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by mjr46 on Fri Jun 24, 2011 4:38 pm

A battery that is fully charged will read 12.6 volts in theroy......the 13.8 that you read is the charging output voltage to the battery from the alt = fine also make sure you put all the wires on the new selonoid back in the proper place expecially the ignition lead/ trigger for the selonoid...if they are in the right place with key held in crank position make sure the ignition trigger to selonoid lights up , if it doesn't = trace it back to possible ignition switch failure

mjr46
BOSS
BOSS

Number of posts : 644
Age : 42
Location : Maryland
Registration date : 2008-02-16

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by FASFOX89 on Fri Jun 24, 2011 4:53 pm

looks like it was just the battery Smile It was reading 12.1 yesterday while car off ,I come home today with new battery in hand and tested old battery before and it was at 10.8....whoa...its never been under 12 the whole couple weeks of this stuff happening..i throw the new battery in and it reads 12.62 ..go take a spin for a little bit and reading after i got back was 13.08..Smile still under the ole watchful eye but the new battery seems to be the ticket even though the bad battery was an october 2010 battery. haaaa...think i may cruise to lowes in bel air tonight.......


Last edited by FASFOX89 on Fri Jun 24, 2011 5:15 pm; edited 1 time in total
avatar
FASFOX89
BOSS
BOSS

Number of posts : 390
Age : 57
Location : Harford county,HdG
Registration date : 2011-06-05

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by FASFOX89 on Fri Jun 24, 2011 4:56 pm

ohhhh ... and thanx for the advice evreeone!!! now back to the fog light drama Smile
avatar
FASFOX89
BOSS
BOSS

Number of posts : 390
Age : 57
Location : Harford county,HdG
Registration date : 2011-06-05

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by AAron83 on Fri Jun 24, 2011 4:57 pm

ive been there with my old fox too. had bizarre electrical problems after installing a new garbage die hard battery. issues drove me nuts and swapped in another battery from home and the issues went away.
avatar
AAron83
COBRA
COBRA

Number of posts : 991
Age : 34
Location : Wheaton MD
Registration date : 2008-01-28

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by etc1006 on Sat Jun 25, 2011 12:14 am

There was a recall on ignition switches in the early 90's on alot of Fords due to a fire hazard. My old 92 LX 5.0 had it done. I have done it to every Fox I've had since. Even if it wasn't your problem, it's cheap insurance.
avatar
etc1006
MACH 1
MACH 1

Number of posts : 186
Age : 47
Location : Elkridge, MD
Registration date : 2011-05-01

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by FASFOX89 on Sat Jun 25, 2011 7:44 am

ok...thanx for that info as i did pick up the ignition switch as well..I'll throw it in too..Smile
avatar
FASFOX89
BOSS
BOSS

Number of posts : 390
Age : 57
Location : Harford county,HdG
Registration date : 2011-06-05

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by FASFOX89 on Sat Jun 25, 2011 9:43 am

oh,and 1 other thing?? how would i know if the ignition switch had been changed?? the reason i ask is that i opened up the steering column and seems the ignition switch has 2 zip ties holding it on?? is this factory from ford or a recall fix..and thanx again!!
avatar
FASFOX89
BOSS
BOSS

Number of posts : 390
Age : 57
Location : Harford county,HdG
Registration date : 2011-06-05

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by etc1006 on Sun Jun 26, 2011 12:21 am

WOW, that definetly isn't right. But I also remember a couple of ties on the harness to a tab on the plug as theres alot of large gauge wires going into a big plastic plug on a 90 degree angle... Makes it a bit more tidy in there for getting the covers on... Factory there were 2 screws that had torque to snap off heads on them. There is several ways to get these off. IIRC the Ford switch comes with Torx security head screws. Dunno about parts store ones...
avatar
etc1006
MACH 1
MACH 1

Number of posts : 186
Age : 47
Location : Elkridge, MD
Registration date : 2011-05-01

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by FASFOX89 on Sun Jun 26, 2011 11:59 am

ok...update ..i didn't look far enuff up in there...there is 2 factory screws in there..I guess the zip ties are for the massive wiring along side of it...and no screws with the AZ part just some wire retaining clip which slides around both pieces but I'm going to put some big zip ties back in there to secure the bundle
avatar
FASFOX89
BOSS
BOSS

Number of posts : 390
Age : 57
Location : Harford county,HdG
Registration date : 2011-06-05

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by etc1006 on Sun Jun 26, 2011 11:15 pm

Just take one of the screws you take out to Lowes or HD, you should be able to find one to fit. Make sure you get it long enough to put a lock washer on it too.
avatar
etc1006
MACH 1
MACH 1

Number of posts : 186
Age : 47
Location : Elkridge, MD
Registration date : 2011-05-01

View user profile

Back to top Go down

Re: ok...here we go...starter/switch/...somethings going on in my 89 vert....sighhhhh

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum